Increased delays for updating prices for products
Resolved

From 05h00 to 21h13 UTC, stores have experienced increased delays (of upwards of hours) when updating product prices via the admin panel or via upload of a price sheet. We have identified that the issue was related to a cache layer of our platform and we applied mitigation actions to fix the behavior. Stores are now operating normally and an incident report will follow in the next days.

Mon, Mar 13, 2023, 09:44 PM
(2 years ago)
·
Affected components

No components marked as affected

Updates

Resolved

From 05h00 to 21h13 UTC, stores have experienced increased delays (of upwards of hours) when updating product prices via the admin panel or via upload of a price sheet. We have identified that the issue was related to a cache layer of our platform and we applied mitigation actions to fix the behavior. Stores are now operating normally and an incident report will follow in the next days.

Mon, Mar 13, 2023, 09:44 PM

Monitoring

We are continuing to monitor for any further issues.

Mon, Mar 13, 2023, 09:14 PM(30 minutes earlier)

Monitoring

We have cleaned the affected cache and products are appearing with the intended prices. We are monitoring our platform to ensure there are no cases left.

Mon, Mar 13, 2023, 09:13 PM

Identified

Cleaning our cache proved to mitigate the issue, but it required us to be very cautious when applying changes in order to not disrupt the rest of the platform. Prices have been updated for most of the affected products, and we're speeding up the mitigation in order to restore the experience faster.

Mon, Mar 13, 2023, 09:08 PM

Identified

We have identified an increase of delays to update product prices. We are working to clean our caches in order to update product prices to the newest data.

Mon, Mar 13, 2023, 07:27 PM(1 hour earlier)