Elevated Errors in the availability service
Incident Report for VTEX
Resolved
Between 07:15 PM and 08:25 PM UTC, we experienced intermittent periods of partially sales degraded. It were caused by a degradation in our Availability Service which is responsible by stock balancer management. The service's database increased the number of commands which degraded its performance and began enqueueing commands and increasing its latency.
We already provisioned more throughput to this database and we are working in measures to prevent this issue in the future.
The service is now operating normally.
Posted Aug 09, 2022 - 21:55 GMT-03:00
Monitoring
We can confirm an improvement in the elevated error rates in our platform. We are monitoring the result of our actions.
Posted Aug 09, 2022 - 17:41 GMT-03:00
Identified
We've identified elevated errors in our product availability service. We are taking measures in order to reestablish normal behavior.
Posted Aug 09, 2022 - 16:47 GMT-03:00
This incident affected: Checkout and WebStore.