Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 06, 2023 - 03:00 UTC
Scheduled
We will be working on improvements to our platform that will require controlled interruptions in Catalog and Seller operations.
As we upgrade our Catalog infrastructure, some stores might experience brief periods of intermittent errors in the administrative environment and store navigation.
As we upgrade our Seller Management infrastructure, seller data will be momentarily read-only. Create, update and delete operations will be unavailable during that period.
Posted Sep 01, 2023 - 17:30 UTC
This scheduled maintenance affected: WebStore and Administrative Environment.