Increased errors in gift card transactions
Incident Report for VTEX
Resolved
This incident has been resolved.

At 20:56 UTC, we identified a critical issue impacting all gift card transactions, resulting in HTTP 415 errors during the authorization process.

At 20:59 UTC, we identified through our logs that the problem had originated after a deployment made at 19:09 UTC, as the error symptoms began to manifest following the deployment. We immediately initiated a rollback process to restore normal gift card transaction authorization functionality.

At 21:22 UTC, we confirmed that gift card transaction authorization was fully restored.

We apologize for any inconvenience this may have caused.
Posted Aug 02, 2023 - 21:45 UTC
Monitoring
We can confirm an improvement in the elevated error rates in our platform. We are monitoring the result of our actions, but most gift card transactions should be coming through without any errors.
Posted Aug 02, 2023 - 21:26 UTC
Update
We are now recovering from the increased error rates. We continue to work towards full recovery.
Posted Aug 02, 2023 - 21:17 UTC
Identified
We have identified the root cause of the increased error rates. We are working to resolve this issue.
Posted Aug 02, 2023 - 20:59 UTC
Investigating
We are investigating increased error rates in gift card transactions.
Posted Aug 02, 2023 - 20:56 UTC
This incident affected: Checkout.