Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 13, 2022 - 00:01 GMT-03:00
Scheduled
We will be working on improvements to our platform that will require periods of downtime in checkout operations and that may cause intermittent errors in store navigation during this window.
Posted Dec 09, 2022 - 10:36 GMT-03:00
This scheduled maintenance affected: Checkout and WebStore.