This incident has been resolved. We will provide further information in a public incident report.
Summary
On Mar 20, 2026, from 19:38 to Mar 21, 2026, 04:19 UTC, affected stores experienced intermittent instability impacting storefront availability and product search.
During this period, some users encountered degraded performance, including increased latency, intermittent errors, page loading failures, and occasional difficulty accessing specific storefront pages.
The incident was caused by cache-related issues that led to broader platform instability. Mitigation actions were applied to stabilize the environment, followed by continuous monitoring to ensure full recovery.
The sales flow was partially and intermittently impacted for a limited number of accounts over a period of approximately 8 hours and 41 minutes.
We apologize for any inconvenience this may have caused.
Resolved
This incident has been resolved. We will provide further information in a public incident report.
Summary
On Mar 20, 2026, from 19:38 to Mar 21, 2026, 04:19 UTC, affected stores experienced intermittent instability impacting storefront availability and product search.
During this period, some users encountered degraded performance, including increased latency, intermittent errors, page loading failures, and occasional difficulty accessing specific storefront pages.
The incident was caused by cache-related issues that led to broader platform instability. Mitigation actions were applied to stabilize the environment, followed by continuous monitoring to ensure full recovery.
The sales flow was partially and intermittently impacted for a limited number of accounts over a period of approximately 8 hours and 41 minutes.
We apologize for any inconvenience this may have caused.
Monitoring
We are still observing a very small and intermittent issue affecting product search for a limited number of stores, with minimal overall impact.
Our teams continue to monitor the platform.We will share the next update as soon as new information becomes available.
Monitoring
We continue to observe a small number of errors affecting some stores.
Our teams remain actively working to ensure full stability.
Monitoring
System performance remains within expected levels.
A small number of isolated errors continue to affect a limited set of stores, with low overall impact.
We will share the next update as soon as there are meaningful developments.
Monitoring
We continue to monitor the platform, which remains stable.
A small number of stores may still experience isolated errors with minimal impact.
We will provide further updates as more information becomes available.
Monitoring
The platform remains stable and operating as expected following the mitigation actions.
At this time, only a very small number of stores are experiencing isolated errors, with minimal impact.
Our teams are actively working to fully resolve these residual issues and ensure complete stability.
Monitoring
We have identified an issue affecting the search functionality and have implemented additional mitigation measures.
The platform remains stable, and our teams are closely monitoring the environment to ensure the effectiveness of the applied actions.
We will provide further updates as more information becomes available.
Monitoring
The platform remains stable following the implemented solution, with no widespread issues observed.
We are continuing to monitor the environment while investigating a small number of residual errors affecting a limited set of stores.
Our teams remain actively engaged to ensure full stability and will provide another update within 30 minutes or sooner if needed.
Monitoring
The platform remains stable following the implemented solution. We are currently verifying a small number of errors affecting some stores.
Our teams are actively investigating these occurrences and closely monitoring the environment to ensure continued stability.
We will share further updates as more information becomes available.
Monitoring
The fix for the issue affecting storefront availability and platform stability has been implemented.
Affected stores should no longer experience slowness, intermittent failures, loading errors, or issues accessing certain pages.
Our incident response team is monitoring to ensure that normal platform behavior is fully reestablished.
We will provide an additional update in the next 30 minutes, or sooner if more information becomes available.
Identified
We have identified cache-related issues as a contributing factor to the instability affecting the platform.
Our team is actively working to implement a solution while minimizing the impact.
We will provide an additional update in the next 30 minutes, or sooner if more information becomes available.
Investigating
We continue to observe intermittent instability affecting multiple stores, with symptoms that may include slowness, intermittent failures, loading errors, and occasional inability to access certain pages.
Mitigation measures are in progress to reduce impact. We will provide further updates as soon as more information becomes available.
Investigating
We are currently investigating an issue causing instability and intermittent behavior.
Multiple stores are experiencing degraded performance, with symptoms that may include slowness, intermittent failures, loading errors, and occasional inability to access certain pages.
Our team is actively working to identify the root cause and implement mitigation measures. We will provide further updates as soon as more information becomes available.
Investigating
We are still investigating the issue affecting storefront access and error rates. Our team continues to analyze the behavior and collect additional data to determine the root cause.
At this time, some users may still experience intermittent errors, including 504 Gateway Timeout, when accessing the store.
We are actively working on mitigation actions and will provide further updates as soon as more information becomes available.
Investigating
We are currently investigating an issue affecting storefront availability.
Affected users may be experiencing intermittent issues accessing the store, including errors such as 504 Gateway Timeout.
Our incident response team is working to identify the root cause and implement a solution.
We will send an additional update in the next 30 minutes, or as soon as we have more information to share.