Write-up published
Resolved
This incident has been resolved. We will provide further information in a public incident report.
Summary
On Aug 5, 2025 from 12:33 to 12:50 UTC, merchants and shoppers faced issues logging in and placing orders. This was an unintended side-effect of an infrastructure configuration change in VTEX ID.
Our global sales flow was partially affected for 17 minutes during this incident.
We apologize for any inconvenience this may have caused.
Timeline
At 12:30 UTC, an infrastructure configuration change was completed by our team.
At 12:33 UTC, our platform health monitoring indicates that orders dropped below forecasted levels for the period.
At 12:36 UTC, our incident response team was notified of the issue.
At 12:47 UTC, our incident response team identified that the infrastructure configuration change was the likely trigger for the drop in orders and started reverting the change.
At 12:50 UTC, the infrastructure configuration change was completely reverted and normal platform behavior was reestablished.
Monitoring
The fix for the issue in VTEX ID has been implemented.
Shoppers should no longer be experiencing issues placing orders. Merchants should no longer be experiencing issues accessing their admin panel. API integrations should no longer be affected.
Our incident response team is monitoring to guarantee that normal platform behavior is fully reestablished.
We will send an additional update in the next 30 minutes, or as soon as we have more information to share.
Identified
We have identified the contributing factors of the issue in VTEX ID.
Our incident response team estimates that the fix will be implemented in the next few minutes.
We will send an additional update in the next 30 minutes, or as soon as we have more information to share.
Investigating
We are currently investigating an issue in VTEX ID, the IAM service responsible for merchant and shopper login flows.
Shoppers may be experiencing issues placing orders. Merchants may be experiencing issues accessing their admin panel. API integrations may be affected as well.
Our incident response team is working to identify the root cause and implement a solution.
We will send an additional update in the next 30 minutes, or as soon as we have more information.