Logistics database maintenance
Complete·Under maintenance

The maintenance has been completed. While the database upgrade took longer than anticipated, we were able to resume normal operations after 30 minutes of total downtime (10 minutes longer than anticipated).

Tue, Jun 10, 2025, 02:44 AM
(2 days ago)
·
Affected components
Order Placement
Shipping Calculation
Catalog Management
Updates

Complete

The maintenance has been completed. While the database upgrade took longer than anticipated, we were able to resume normal operations after 30 minutes of total downtime (10 minutes longer than anticipated).

Tue, Jun 10, 2025, 02:44 AM

In progress

All metrics have returned to expected levels. We will keep monitoring until the end of the maintenance window.

Tue, Jun 10, 2025, 02:36 AM

In progress

The database upgrade has taken more time than anticipated, but our mitigation strategies are into effect and latency metrics are returning to normal.

Tue, Jun 10, 2025, 01:52 AM(43 minutes earlier)

In progress

Maintenance has started

Tue, Jun 10, 2025, 01:00 AM(52 minutes earlier)

Scheduled

Rescheduled for Jun 10, 2025 at 01:00 - 03:00 UTC

Wed, May 28, 2025, 11:47 AM(1 week earlier)

Scheduled

Scheduled for May 29, 2025 at 01:00 - 03:00 UTC

We will work on improvements to our platform that require controlled interruptions in one of our Logistics databases.

As we upgrade our Availability database, some stores might experience brief periods (under 20 minutes) of intermittent errors in Checkout and Logistics operations such as performing orderForm simulations, adding items to cart or placing orders.

This is required to enhance the reliability of inventory availability operations. We thank you in advance for your understanding as we upgrade our platform to serve you better, our valued customers and partners.

Mon, May 26, 2025, 10:06 PM(1 day earlier)