This incident has been resolved.
Summary
On May 14, 2026, from 04:49 to 07:57 UTC, some merchants experienced issues in order management, particularly in processing the orders status workflow.
Around 07:41 UTC we noticed an improvement in order processing, normalizing by 07:57 UTC.
Shoppers were not directly affected by this incident, only the post-purchase order processing was affected.
We apologize for any inconvenience this may have caused.
Resolved
This incident has been resolved.
Summary
On May 14, 2026, from 04:49 to 07:57 UTC, some merchants experienced issues in order management, particularly in processing the orders status workflow.
Around 07:41 UTC we noticed an improvement in order processing, normalizing by 07:57 UTC.
Shoppers were not directly affected by this incident, only the post-purchase order processing was affected.
We apologize for any inconvenience this may have caused.
Monitoring
The fix for the issue affecting post purchase flow has been implemented.
Affected stores should no longer experience stuck in orders and are now being processed.
Our incident response team is monitoring to guarantee that normal platform behavior is fully reestablished.
We will send an additional update in the next 30 minutes, or as soon as we have more information to share.
Investigating
We continue to observe delay in the post purchase flow.
We are actively working on mitigation actions and will provide further updates as soon as more information becomes available.
Investigating
We are still investigating the issue affecting the post purchase flow. Our team continues to analyze the behavior and collect additional data to determine the root cause.
We will provide an additional update in the next 30 minutes, or sooner if more information becomes available.
Investigating
We are currently investigating an issue affecting post purchase flow.
Affected users may see orders stuck in a particular status, with updates not progressing as expected.
Our incident response team is working to identify the root cause and implement a solution.
We will send an additional update in the next 30 minutes, or as soon as we have more information to share.