This incident has been resolved.
Summary
On May 09, 2026, from 06:24 to 07:16 UTC, some merchants experienced issues in order management, particularly in advancing the orders workflow in Processing and Payment Pending status.
We apologize for any inconvenience this may have caused.
Resolved
This incident has been resolved.
Summary
On May 09, 2026, from 06:24 to 07:16 UTC, some merchants experienced issues in order management, particularly in advancing the orders workflow in Processing and Payment Pending status.
We apologize for any inconvenience this may have caused.
Monitoring
The fix for the issue in Orders has been implemented.
Merchants may be experiencing issues in order management, particularly in advancing the orders workflow in Processing and Payment Pending status.
Our incident response team is working to reprocess affected orders and transactions as soon as possible.
We will send an additional update in the next 30 minutes, or as soon as we have more information to share.